斐讯设备

checkinpanel安装依赖时出现错误Permission denied

daimafengzi · 2月12日 · 2022年本文共945个字 · 预计阅读4分钟2521次已读

安装命令:

apk add gcc libffi-dev musl-dev openssl-dev python3-dev && pip3 install bs4 cryptography~=3.2.1 json5 requests rsa

错误提示:

ERROR: http://mirrors.aliyun.com/alpine/v3.11/main: Permission denied
WARNING: Ignoring http://mirrors.aliyun.com/alpine/v3.11/main: No such file or directory
fetch http://mirrors.aliyun.com/alpine/v3.11/community/aarch64/APKINDEX.tar.gz
ERROR: http://mirrors.aliyun.com/alpine/v3.11/community: Permission denied
WARNING: Ignoring http://mirrors.aliyun.com/alpine/v3.11/community: No such file or directory
ERROR: unable to select packages:
  freetype-dev (no such package):
    required by: world[freetype-dev]
  gcc (no such package):
    required by: world[gcc]
  jpeg-dev (no such package):
    required by: world[jpeg-dev]
  libffi-dev (no such package):
    required by: world[libffi-dev]
  musl-dev (no such package):
    required by: world[musl-dev]
  openssl-dev (no such package):
    required by: world[openssl-dev]
  python3-dev (no such package):
    required by: world[python3-dev]
  zlib-dev (no such package):
    required by: world[zlib-dev]

解决办法:

全局用楼梯。

0 条回应